This topic can no longer be replied to because it has been locked.

Product Attribute set to default option on product export
Gravatar
Joined: 2016-08-30
Posts: 7
Hello,

i have updated to last version 1.0.6.

We have an big issue here:

When a product is exported to mailchimp, your extension fills 3 fields:
MailChimp last sync timestamp
2016-08-30 12:03:11

MailChimp Error Description

MailChimp Modified

BUT if you have any attribute as Dropdown and you have an option set "By default" on it, you extension set this attribute as "By default" value, even if you have already selected option on this attribute.

This cost me to all of our products setted to the same brand.

Now i'm restoring database table to yesterday state and have all products with the same brand.

To temporary fix this issue i have unsetter "by default" value to none but you have to fix that on the extension.

Thank you
Gravatar
Joined: 2016-09-10
Posts: 4
This has just happened to my Magento store with MailChimp For Magento v1.0.6 by ebizmarts - so it definitely does affect attributes!

I will also have to restore my database from last night's backup.

Not good ebizmarts!
Gravatar
Joined: 2016-08-30
Posts: 7
Yes,

i also detected that the export process deletes url_key attribute.

I hope they fix all problems soon
Gravatar
Joined: 2016-09-12
Posts: 1
This is a very serieus issue and it changes a lot of non flat product attributes. Any news from the developer on this, this should be solved as soon as posisble because all shop owners can get intro trouble with this.
Gravatar
Joined: 2014-08-07
Posts: 2628
Hello,

Sorry for the delay. You are right about this. The product needs to be loaded again since the collection seems to overwrite some associated values.

You can solve it by removing this line and place these ones on the file at app/code/community/Ebizmarts/MailChimp/Model/Api/Products.php.

Sorry for the troubles caused.

Regards,
Santiago.
Gravatar
Joined: 2016-09-10
Posts: 4
Hi Santiago- you should update the extension ASAP! I have spend $160 so far fixing my store's attributes and other errors caused by restoring!

Kind regards,
Peter
Gravatar
Joined: 2014-08-07
Posts: 2628
Hello,

Does this keeps happening after version 1.1.1? This should be fixed already.
If it does please give me as much information as you can about how to reproduce it.

Regards,
Santiago.
Gravatar
Joined: 2016-09-10
Posts: 4
Hi Santiago,

We are re-developing in Mage 1.9, but currently using 1.7 - does v1.2.6.1 work in 1.7?

Regards,
Peter
Gravatar
Joined: 2014-08-07
Posts: 2628
Hello,

Yes MageMonkey 1.2.6.1 does work in Magento 1.7. I will test MailChimp For Magento in this Magento version to see what is the problem you are experiencing even after updating to version 1.1.1.

Regards,
Santiago.
Gravatar
Joined: 2016-09-10
Posts: 4
Hi Santiago,

Apart from the attribute default reset issue, the extension sync'd 13,000 from users from Mage to my Mailchimp list without any prompting - setting off their "Omnivore" software - thus I could not send any mail unless i removed them from my list - taking with it an entire day's usual subscribers!

Kind regards,
Peter

NEWSLETTER

Subscribe to our newsletter to receive emails and useful news articles