This topic can no longer be replied to because it has been locked.

Sage Pay Orphan Transactions `2014 : The Transaction was Registered Successfully`
Gravatar
Joined: 2017-01-24
Posts: 2
I am using Sage Pay Suite Community Edition v3.6.4 by ebizmarts in my magento 1.9.1.0 site. Last day I tried to place two orders from magento adminpanel with Sagepay as payment method. But after submitting Sagepay details it redirected to the website checkout cart page and no order created and these transactions became Sage Pay Orphan Transactions with Original Error Detail` > "2014 : The Transaction was Registered Successfully.'. But in the same day there was also placed some other successful Sagepay transactions.

The other thing I noticed is the adminside `Sage Pay Orphan Transactions` detail view popup shows the error message "Unable to connect with SagePay API: Incorrect API user/password or the API user might be locked out (This is configured in: Sage Pay Suite [Backend - Reporting & Third Man API Integration])".


I have already set up the `Sage Pay Suite [Reporting & Third Man API Integration]` details correctly then what will be the reason for this orphan transactions and this error message ? Please help me to sort this issue.

Thanks
Gravatar
Joined: 2015-04-08
Posts: 784
Hello,

- Orphan Transactions with Original Error Detail` > "2014
Is there any error on Magento or SagePaySuite logs around the time the order was placed?

Regards
Gravatar
Joined: 2017-01-24
Posts: 2
Hi,

I didn't find any critical error for this. Please check my log details below

SagePaySuite_REQUEST.log

2017-01-23 12:18:15.000000 (1485173895.61) DEBUG: Array
(
[VPSProtocol] => 3.00
[Status] => OK
[StatusDetail] => 2014 : The Transaction was Registered Successfully.
[VPSTxId] => {F9414413-XXXXXXXXXXXXXX}
[SecurityKey] => XXXXXXXXXXXXXX
[NextURL] => https://checkout.sagepay.com/gateway/service/cardselection?vpstxid={F9414413-XXXXXXXXXXXXXX}
)

SagePaySuite_RawResponse.log

2017-01-23 12:18:15.000000 (1485173895.61) DEBUG: VPSProtocol=3.00
Status=OK
StatusDetail=2014 : The Transaction was Registered Successfully.
VPSTxId={F9414413-XXXXXXXXXXXXXX}
SecurityKey=XXXXXXXXXXXXXX
NextURL=https://checkout.sagepay.com/gateway/service/cardselection?vpstxid={F9414413-XXXXXXXXXXXXXX}


SagePaySuite_POST_Requests.log

2017-01-23 12:18:32.000000 (1485173912.89) DEBUG: Array
(
[VPSProtocol] => 3.00
[TxType] => PAYMENT
[VendorTxCode] => XXXXXXXXXXXXX
[VPSTxId] => {F9414413-XXXXXXXXXXXXXX}
[Status] => OK
[StatusDetail] => 0000 : The Authorisation was Successful.
[TxAuthNo] => XXXXXXXX
[AVSCV2] => ALL MATCH
[AddressResult] => MATCHED
[PostCodeResult] => MATCHED
[CV2Result] => MATCHED
[GiftAid] => 0
[3DSecureStatus] => NOTCHECKED
[CardType] => MC
[Last4Digits] => XXXX
[VPSSignature] => XXXXXXXXXXXX
[DeclineCode] => 00
[ExpiryDate] => XXXX
[BankAuthCode] => XXXX
)


My magento adminside `Sage Pay Orphan Transactions` detail page shows only the error message "Unable to connect with SagePay API: Incorrect API user/password or the API user might be locked out (This is configured in: Sage Pay Suite [Backend - Reporting & Third Man API Integration])" and there is not any transaction details to check.
Gravatar
Joined: 2015-04-08
Posts: 784
Hello,

Did you check all exception logs and general.log around 2017-01-23 12:18?

Regards

NEWSLETTER

Subscribe to our newsletter to receive emails and useful news articles