Installation error
Gravatar
Joined: 2015-03-31
Posts: 11
Hellow we are getting the following error when running

php bin/magento module:enable Ebizmarts_MailChimp
php bin/magento setup:upgrade

'Module 'Ebizmarts_MailChimp':
Area code not set: Area code must be set before starting a session'

We followed instructions and installed composer require ebizmarts/mailchimp-lib as well.
Gravatar
Joined: 2018-08-14
Posts: 235
Hi,

Thanks for contacting us.

Can you tell me your current mailchimp and magento version numbers?
Gravatar
Joined: 2015-03-31
Posts: 11
2.25 and 10.32
Gravatar
Joined: 2018-08-14
Posts: 235
Hi,

Can you tell how you installed the module?
Gravatar
Joined: 2015-03-31
Posts: 11
Manually uploaded file to app/code/Ebizmarts/MailChimp
Ran composer require ebizmarts/mailchimp-lib
Then bin/magento setup:upgrade
Gravatar
Joined: 2015-03-31
Posts: 11
This is the exception error. We definitely have the 10.32 package uploaded.

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Ebizmarts_MailChimp data: current version - 1.0.29, required version - 1.0.32


Gravatar
Joined: 2018-08-14
Posts: 235
Hi Andre,

Can you tell me step by step how you installed it?
Gravatar
Joined: 2015-03-31
Posts: 11
We had a previous version installed through composer. Can you please let me know how to completely remove the module and we'll start again.
Gravatar
Joined: 2015-03-31
Posts: 11
To install we uploaded 10.32 to app/code/Ebizmarts/MailChimp
then composer require ebizmarts/mailchimp-lib
then bin/magento setup:upgrade
Gravatar
Joined: 2018-08-14
Posts: 235
Hi Andre,

We had a previous version installed through composer.

You removed the previous version?

To install we uploaded 10.32 to app/code/Ebizmarts/MailChimp
then composer require ebizmarts/mailchimp-lib
then bin/magento setup:upgrade

If you uploaded the version 1.0.32 manually but you didn't remove the previous version that you have installed using composer there can be the problem.

To uninstall the version that you installed manually you only need delete the folder Ebizmarts/MailChimp after that run php bin/magento setup:upgrade
To uninstall the version that you installed using composer run on the console php composer remove mailchimp/mc-magento2 and php bin/magento setup:upgrade

NEWSLETTER

Subscribe to our newsletter to receive emails and useful news articles