This topic can no longer be replied to because it has been locked.

Won't sync again following Mailchimp for Magento upgrade
Gravatar
Joined: 2012-12-06
Posts: 9
Hello,

I upgraded the extension from 1.1.7 to 1.1.15 and now it won't sync again with Mailchimp.

It shows the error messages "No MailChimp store was created for this scope, parent scopes might be sending data for this store anyways.
You can create a new MailChimp store for this scope by configuring a new list for this scope."

Product image were almost all outdated on Mailchimp so I used the "Reset Mailchimp Store" button on Magento. This removed the store on Mailchimp, but now it wont sync again.

The following message is displayed on Magento but the store is never created on Mailchimp :
"A MailChimp store with the same domain already exists in this account. You need to have a different URLs for each scope you set up the ecommerce data. Possible solutions HERE and HERE
A MailChimp store with the same domain already exists in this account. You need to have a different URLs for each scope you set up the ecommerce data. Possible solutions HERE and HERE
Looks like your MailChimp store was deleted. Attempting to create a new one."

It never seems to create a new store on MailChimp as I upgraded the extension on the 14th March and we still don't have any "Connected Site" on MailChimp.

I already took a look at the possible workarounds here : https://ebizmarts.com/forums/topics/view/28025

1: I have no parent scope, as I have configured all the Mailchimp settings on the "default" Magento scope.
2: No multiple stores configured for Mailchimp. We have 3 store views for languages, but they all are using the same domain, and the Mailchimp settings are only set on the "default" Magento config scope and not for each store view.
3: On Mailchimp we don't have any Connected Site anymore. It seems to have been completely removed. But when I click on the "Reset Mailchimp Store" button, it shows multiple messages indicating that "a MailChimp store with the same domain already exists in this account", even if we don't have any Connected Site displayed on MailChimp.


Our website is http://www.batiplus.ch.

What can we do?

Thanks for your help.

Best regards,

Leeroy
Gravatar
Joined: 2014-08-07
Posts: 2628
Hello Leroy,

Please note this forum has been closed.
You can contact us at https://ebizmarts.com/contact-us

Kind Regards.

NEWSLETTER

Subscribe to our newsletter to receive emails and useful news articles